SSL certificate problems
Incident Report for ESS (Public)
Resolved
The Heartbleed bug (http://heartbleed.com/) have now been addressed for all our regional endpoints.
Posted Apr 08, 2014 - 19:21 UTC
Identified
An error relating to updating SSL certs due to the Heartbleed issue causes problems on some load balancers. Certs have been rolled back and we are preparing proper replacement certificates.
Posted Apr 08, 2014 - 19:00 UTC