Elastic Support Portal unavailable

Incident Report for Elastic Cloud (Public)

Resolved

The Elastic Support Portal remains available and steady - at this time, we are considering this incident resolved.
Posted Sep 16, 2026 - 15:38 UTC

Monitoring

We are seeing signs of recovery on the Elastic Support Portal, and customers should now be able to access as normal. We will continue monitoring for 30 minutes before marking this incident as resolved.
Posted Sep 16, 2026 - 14:49 UTC

Investigating

We are currently aware that some customers may be unable to access the Elastic Support Portal at this time. We are working with our provider to investigate.

If you need to contact support in the meantime, please contact support@elastic.co.
Posted Sep 16, 2026 - 13:17 UTC