Elevated rate of HTTP/502 responses from proxy
Incident Report for ESS (Public)
Resolved
Having determined that the impact of this issue is minimal, we are closing this incident. Our engineers have identified a number of issues which are likely contributing to the slightly elevated HTTP/502 error rate, and work continues to validate fixes for these issues. Once we are confident we have resolved the underlying issues, we will update this post with a summary of the investigation and indicate when the fixes will be released.
Posted Oct 12, 2021 - 23:23 UTC
Update
After analyzing monitoring data, we have determined that majority of the HTTP/502 errors are related to <0.1% requests resulting in HTTP/502. This is still an elevated rate and the engineers are investigating the root cause, but a much smaller customer impact than we previously assessed.
Posted Oct 12, 2021 - 16:36 UTC
Investigating
We are observing an elevated number of HTTP/502 responses from proxy layer across all regions. Our engineers are analyzing the telemetry and investigating the root cause.
Posted Oct 12, 2021 - 15:28 UTC
This incident affected: Global services (Kibana connectivity: Global, Elasticsearch connectivity: Global, APM connectivity: Global, App Search connectivity: Global, Enterprise Search connectivity: Global).