Customers experiencing AWS Marketplace errors on signup
Incident Report for ESS (Public)
Resolved
We've rolled out the code fix to production and confirmed that the issue is resolved. Impacted customers should try signing up with AWS marketplace again.
Posted Jan 22, 2021 - 16:43 UTC
Update
Our dev teams are working on validating a proposed fix for the problem. Signups through the AWS Marketplace will still fail at this time. We anticipate having a fix within the next few hours. The next update will be either in 4 hours or when we start pushing the fix, whichever is soonest. Please reach out to support@elastic.co if you need help in the meantime.
Posted Jan 22, 2021 - 05:58 UTC
Update
Our dev teams are working on validating a proposed fix for the problem. Signups through the AWS Marketplace will still fail at this time. We anticipate having a fix within the next few hours. The next update will be either in 2 hours or when we start pushing the fix, whichever is soonest. Please reach out to support@elastic.co if you need help in the meantime.
Posted Jan 22, 2021 - 03:52 UTC
Update
Our dev teams are working on validating a proposed fix for the problem. Signups through the AWS Marketplace will still fail at this time. We anticipate having a fix within the next few hours. The next update will be either in 2 hours or when we start pushing the fix, whichever is soonest. Please reach out to support@elastic.co if you need help in the meantime.
Posted Jan 22, 2021 - 01:07 UTC
Update
Our dev teams are working on validating a proposed fix for the problem. Signups through the AWS Marketplace will still fail at this time. We anticipate having a fix within the next few hours. The next update will be either in 2 hours or when we start pushing the fix, whichever is soonest. Please reach out to support@elastic.co if you need help in the meantime.
Posted Jan 21, 2021 - 20:31 UTC
Identified
We have identified a problem with signups through AWS Marketplace. A change in backend APIs led to a bug within the signup process. Customers who have signed up in the past 24 hours may see "The AWS Marketplace billing account associated with your Elastic Cloud account has been disconnected" when clicking email verification links.

The team is currently working on a fix for the issue and we will provide updates within the hour.
Posted Jan 21, 2021 - 19:45 UTC
This incident affected: Global services (AWS Marketplace).