Website dynamic pricing page crashing when selecting Azure
Incident Report for ESS (Public)
Resolved
We were able to identify the issue and apply a fix so the dynamic pricing page is working as intended for Azure once more.
Posted Apr 07, 2021 - 21:32 UTC
Investigating
We are currently investigating an issue with our website's dynamic pricing page crashing when trying to select Azure as the provider. Please note that there is no impact to actual Cloud services or deployments in Azure this is purely an issue with the dynamic pricing page itself.

In the meantime you can view the non-dynamic pricing table here: https://cloud.elastic.co/deployment-pricing-table
Posted Apr 07, 2021 - 21:20 UTC