Trial account signup flow may be impacted
Incident Report for Elastic Cloud
Resolved
This incident has been resolved.
Posted 28 days ago. Oct 17, 2018 - 17:13 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 28 days ago. Oct 17, 2018 - 16:56 UTC
This incident affected: Cluster Management (Cluster Management Console Service).