New Users Unable to Sign Up
Incident Report for Elastic Cloud
Resolved
Operational emails from January 26, 2020 0400 to January 27, 2020 1900 have now been sent out, and all impact from this incident is resolved. Should you have any additional questions or issues, as always, please reach out to your support team! Thank you for your patience!
Posted Jan 30, 2020 - 18:08 UTC
Update
We are continuing work on operational emails that didn't go out during the impacted time period. The next status update will be posted as soon as all the emails will be successfully processed.
Posted Jan 30, 2020 - 02:09 UTC
Update
We are processing operational emails that didn't go out during the impacted time period and will be resending them shortly. Those emails are watcher whitelist links and user verifications. If you needed a password reset and didn't receive the associated email, we request you to go through the normal reset password workflow. We'll have another update in 6 hours.
Posted Jan 29, 2020 - 19:49 UTC
Update
We are continuing to work on fix for the remaining inconsistencies for queued events such as email verifications, password changes, and billing changes. We will provide next status update as more information becomes available.
Posted Jan 29, 2020 - 00:46 UTC
Update
Still actively working out the remaining inconsistencies for queued events such as email verifications, password changes, and billing changes. We expect to know more within the next 4 hours and will provide an update at that time.
Posted Jan 28, 2020 - 20:36 UTC
Update
We have deployed the initial fix for the user and deployment inconsistencies that occurred between January 26, 2020 0400 UTC and January 27, 2020 1900 UTC. We are still working to resolve additional inconsistencies around queued events that occurred during that time period such as email verifications, password changes, and billing changes. We will provide more details within the next two hours.
Posted Jan 28, 2020 - 18:28 UTC
Update
We are preparing to deploy an initial fix for the user and deployment inconsistencies that occurred between Jan 26, 2020 04:00 UTC and Jan 27, 2020 19:00 UTC. There is more work to be done to resolve the remaining issues, but this covers most of the cases. We'll provide more details within the next 2 hours.
Posted Jan 28, 2020 - 16:34 UTC
Monitoring
We've resolved issue that caused the inconsistency and currently we are monitoring situation. The users that tried to convert their accounts to paid, change password or email between Jan 26, 2020 04:00 UTC and Jan 27 19:00 UTC may still see inconsistency in user console. We are still working on a plan to fix the inconsistencies and will update status as soon as new information will be available.
Posted Jan 28, 2020 - 02:05 UTC
Update
We're still working on a plan to fix the inconsistencies. We'll provide another update in the next hour.
Posted Jan 27, 2020 - 23:50 UTC
Update
We're wrapping up our audit of the inconsistencies and working on a plan to apply the fix. We'll provide another update in the next hour.
Posted Jan 27, 2020 - 22:29 UTC
Update
Current status: we're still working on auditing the inconsistencies, but we'll provide another update in the next hour.
Posted Jan 27, 2020 - 21:33 UTC
Identified
We have identified the source of the inconsistencies and are working on a plan to resolve those. Any changes between Jan 26, 2020 04:00 UTC and Jan 27 19:00 UTC to users or deployments may have been impacted. We'll update progress on resolving those within the next 2 hours.
Posted Jan 27, 2020 - 19:44 UTC
Investigating
Upon further investigation, we discovered some further inconsistencies with converting trial accounts to paid users. Engineers are currently investigating and we'll provide another update in 30 minutes.
Posted Jan 27, 2020 - 18:52 UTC
Monitoring
We finished deploying our fix and user signups are working again. At this point we consider the issue resolved. We'll keep watch on services and ensure there is no further impact.
Posted Jan 27, 2020 - 16:32 UTC
Investigating
Since Sunday Jan 26, 2020 starting at around 04:20 UTC, new users would have been unable to sign up for Elastic cloud. We are investigating and testing a possible fix and should have an update in 30 minutes. Current users and deployments are not affected by this.
Posted Jan 27, 2020 - 15:48 UTC
This incident affected: Global services (Cloud console).