Failures in API Console
Incident Report for Elastic Cloud
Resolved
All affected components have been re-deployed with the correct versions. This incident has been resolved.
Posted 14 days ago. Jun 06, 2019 - 06:44 UTC
Monitoring
The deployment of one of our API services has completed and users should no longer be experiencing any issues when interacting with deployments via the console. Executing requests via the API Console, and accessing deployment snapshots should be succeed.

We're still in the process of re-deploying the second API service, however there should be no further user impact whilst this completes.
Posted 14 days ago. Jun 06, 2019 - 06:15 UTC
Update
We've reviewed the versions of other related components and have found another service which requires re-deployment. We're working on re-deploying this second component with the correct version, however this will delay the resolution of this incident.

We expect both components to be fully deployed within the next 45 minutes, and will update this incident at that time or as any changes come to hand.
Posted 14 days ago. Jun 06, 2019 - 05:58 UTC
Identified
We've identified a version mismatch in some recently deployed components. We believe this to be causing the failures in executing requests via the API Console.

We're currently working on redeploying this component with the correct version, and anticipate this will be complete within the next 15 minutes.

We'll update this issue when this deployment is complete.
Posted 14 days ago. Jun 06, 2019 - 05:38 UTC
Investigating
We're encountering issues executing requests against a deployment via the customer console. Users may experience errors when executing requests via the 'API Console' or when viewing, or restoring snapshots for a deployment.

There are no general cluster connectivity issues.

We're currently investigating this issue and will update this status page within the next hour, or as more information comes to hand.
Posted 14 days ago. Jun 06, 2019 - 05:26 UTC
This incident affected: Cluster Management (Cluster Management API, Cluster Snapshots).