Invoice downloads not working
Incident Report for ESS (Public)
Resolved
This incident has been resolved.
Posted Sep 13, 2021 - 21:14 UTC
Monitoring
The fix has been implemented and the issue has been resolved
Posted Sep 13, 2021 - 15:28 UTC
Identified
We have identified an issue preventing the customers from downloading invoices. The issue has been identified and we are testing the fix.
Posted Sep 13, 2021 - 14:55 UTC
This incident affected: Global services (Cloud console).