Slow responses in Billing APIs
Incident Report for ESS (Public)
Resolved
We are no longer seeing increased latency in calls to our billing APIs.
Posted Jan 13, 2023 - 20:24 UTC
Monitoring
We are seeing a decline in high latency for calls of our Billing APIs which were impacting both API users and the billing UI. While users may still see slow responses for both the UI and API related to billing history, we expect the latency of these calls to continue to decrease. We are continuing to monitor.
Posted Jan 13, 2023 - 15:40 UTC
Investigating
We are experiencing higher latency of some of our Billing APIs which may result in slow responses for both the UI and API users related to billing history. We are investigating.
Posted Jan 12, 2023 - 19:45 UTC
This incident affected: Global services (Cloud console).