Trial Signups Are Not Working
Incident Report for Elastic Cloud
Resolved
We've finished sending out the last trial signup emails and consider this issue resolved.
Posted Mar 03, 2020 - 21:08 UTC
Monitoring
New trial signups should work now. There are some users that attempted to sign up over the last several hours for which we will retroactively send signup emails. We'll provide an update on that effort in 4 hours.
Posted Mar 03, 2020 - 19:01 UTC
Investigating
We're investigating trial signups failures for new users. Engineers are looking into the issue and we will provide more details in 30 minutes.
Posted Mar 03, 2020 - 18:07 UTC