Delayed, or not delivered, mail to some recipients
Incident Report for Elastic Cloud
Resolved
This issue has been resolved at this time and we have resent failed emails to the small number of users impacted. Thank you again for your patience during this situation and please don't hesitate to let us know if you're experiencing further issue with receiving email from us.
Posted Oct 23, 2019 - 15:47 UTC
Identified
We have received reports of some users not receiving emails, namely trial confirmation emails and/or password reset emails. At this time the issue seems isolated to Microsoft based email recipients and the failure rate is a small percentage.

We have identified the issue and are currently working with our upstream email service provider to correct the problem, however during at this time emails may not be delivered, and/or may be delayed.

We apologize for the inconvenience and will have another update on this issue within the hour.
Posted Oct 23, 2019 - 14:49 UTC
This incident affected: Global services (Email notifications).