Kibana SSO login not functional

Incident Report for ESS (Public)

Resolved

The fix for this issue has been fully deployed, and logging into Kibana with Elastic Cloud SSO now functions correctly.
Posted Aug 20, 2020 - 13:11 UTC

Monitoring

The issue has been identified as related to a code release.

The "Log in with Elastic Cloud" button for Kibana introduced as part of this release is currently non-functional for new deployments created after 18th Aug 1300 UTC. Clicking this button will lead to a 404. Next time “Launch Kibana” is clicked on in the Cloud UI the usual login screen will not appear, but instead will be taken directly to the 404 page. Deleting cookies will fix this.

We expect to have a fix for this issue in 1-2 days. Once we have confirmed the fix, we will close out this incident.
Posted Aug 18, 2020 - 14:22 UTC

Investigating

We are currently investigating an issue in a number of ESS regions with SSO login to Kibana. This only affects new deployments created in those regions.
Posted Aug 18, 2020 - 13:34 UTC
This incident affected: Azure Washington (azure-westus2) (Kibana connectivity: Azure azure-westus2), GCP Singapore (asia-southeast1) (Kibana connectivity: GCP asia-southeast1), AWS São Paulo (sa-east-1) (Kibana connectivity: AWS sa-east-1), and AWS London (eu-west-2) (Kibana connectivity: AWS eu-west-2).