Search Sessions feature in Kibana 7.12.0 causes potential performance degradation
Incident Report for ESS (Public)
Resolved
We have applied a mitigation for all affected clusters. We've had to disable search sessions for all 7.12.0 Kibanas due to this bug, and we apologize for any inconvenience this may have caused you. Please reach out to Elastic Support (support@elastic.co) if you have any concerns related to this incident.
Posted Apr 09, 2021 - 03:20 UTC
Investigating
The 7.12.0 Kibana release introduced the Search Sessions feature, which allows long running searches to execute in the background and for users to revisit them upon their completion. A bug in the feature has been discovered that leads to 100% CPU utilization when Search Sessions are used in conjunction with non default Spaces. The solution for all users of 7.12.0 is to disable search sessions, delete all objects of type search-session, delete all search session monitoring tasks, and restart Kibana.

Status: We are currently completing the required steps to resolve this issue in all regions.

Expected Impact: You may see that Kibana has been restarted in your environment. If you experience any other symptoms or have concerns please contact Elastic Support (support@elastic.co)

Further updates will follow within 2 hours
Posted Apr 08, 2021 - 16:19 UTC