Connectivity disruption for AWS Bahrain (me-south-1)

Incident Report for Elastic Cloud (Public)

Update

This incident remains ongoing. We continue to monitor the situation in AWS Bahrain (me-south-1) and are actively supporting all impacted customers through our support channels.

As this incident has no ETA for mitigation, our status updates for this incident will be on a weekly basis, or sooner if there is a significant change in status.

For any further assistance, please feel free to reach out to Elastic support by either opening a case in our Support portal (https://support.elastic.co) or by emailing support@elastic.co.
Posted Mar 24, 2026 - 11:09 UTC

Update

We have identified a further potential disruption to our services hosted in the AWS Bahrain (me-south-1) region.
We are working to determine the scope of this impact, and have engaged with AWS as the providers in this investigation.

Further updates will be posted within the hour, or when we have further information.
Posted Mar 24, 2026 - 09:29 UTC

Update

There are no new updates. This incident remains ongoing. We continue to monitor the situation in AWS Bahrain (me-south-1) and are actively supporting all impacted customers through our support channels.

As this incident has no ETA for mitigation, our status updates for this incident will be on a weekly basis, or sooner if there is a significant change in status.

For any further assistance, please feel free to reach out to Elastic support by either opening a case in our Support portal (https://support.elastic.co) or by emailing support@elastic.co.
Posted Mar 23, 2026 - 16:20 UTC

Update

This incident remains ongoing. We continue to monitor the situation in AWS Bahrain (me-south-1) and are actively supporting all impacted customers through our support channels.

As this incident has no ETA for mitigation, our status updates for this incident will be on a weekly basis, or sooner if there is a significant change in status.

For any further assistance, please feel free to reach out to Elastic support by either opening a case in our Support portal (https://support.elastic.co) or by emailing support@elastic.co.
Posted Mar 16, 2026 - 19:46 UTC

Update

This incident remains ongoing. We continue to monitor the situation in AWS Bahrain (me-south-1) and are actively supporting all impacted customers through our support channels.

As this incident has no ETA for mitigation, our status updates for this incident will be on a weekly basis, or sooner if there is a significant change in status.

For any further assistance, please feel free to reach out to Elastic support by either opening a case in our Support portal (https://support.elastic.co) or by emailing support@elastic.co.
Posted Mar 09, 2026 - 15:01 UTC

Identified

We are aware of connectivity and power issues affecting AWS Bahrain (me-south-1) due to localized power issues. We are awaiting further updates from AWS and will update here once we have more information.
Posted Mar 02, 2026 - 06:23 UTC
This incident affects: AWS Bahrain (me-south-1) (AWS EC2 Health: me-south-1, Snapshot Storage Infrastructure (S3): me-south-1, Deployment orchestration (Create/Edit/Restart/Delete): AWS me-south-1, APM connectivity: AWS me-south-1, AWS Infrastructure health: me-south-1, Elasticsearch connectivity: AWS me-south-1, Kibana connectivity: AWS me-south-1).