New Cloud sign ups are not working
Incident Report for ESS (Public)
Resolved
Signups are now functioning normally. If you continue to see problems, please clear browser cookies for cloud.elastic.co and try again.
Posted Nov 16, 2020 - 08:17 UTC
Monitoring
We've had some successful signups in the last 20 minutes. Will continue to monitor the situation.
Posted Nov 16, 2020 - 07:42 UTC
Investigating
We have discovered an issue that prevents new users from signing up to Elastic Cloud-- we are currently investigating the cause. Existing users do not seem to be impacted at this time. We will update the status on this issue in one hour.
Posted Nov 16, 2020 - 07:17 UTC
This incident affected: Global services (Cloud console).