Issues with Usage Statements
Incident Report for ESS (Public)
Resolved
The incident has been resolved and all past usage statements have been corrected.
Posted Jul 06, 2022 - 22:51 UTC
Identified
We've identified an issue with the Credit Balance and Active Credits sections of some Usage Statements for the March, April and May 2022 billing periods. The issue impacts the totals displayed in the PDF reports only, not the actual credit balances or billed amounts. We're working on a fix and will be correcting the affected reports.
Posted Jun 27, 2022 - 14:14 UTC