Kibana/APM network connectivity issues in AWS eu-central-1
Incident Report for Elastic Cloud
Resolved
Based on the data gathered over the past hour we can conclude the connectivity between Kibana/APM and Elasticsearch clusters has been successfully restored. Customers should not experience any issues with connectivity to Kibana instances.

What happened: The Elastic Cloud Proxy tier is currently at the end of an implementation phase which has introduced a new Cloud Proxy for handling client requests. Part of the implementation phase involved using haproxy to conditionally route traffic between the old and new proxies so that we could introduce the change gradually and with least impact.
As part of the work to remove haproxy from this stack a configuration change was made to the AWS eu-central-1 region which resulted in inter-deployment (Kibana -> Elasticsearch; APM -> Elasticsearch) communication issues.

This change has now been reverted.
Posted 4 months ago. Jun 07, 2019 - 13:03 UTC
Monitoring
Problematic proxy release has been successfully rolled back. Connectivity to Kibana instances should now be restored. We are currently monitoring the situation and will provide more details about the incident within the next 60 minutes.
Posted 4 months ago. Jun 07, 2019 - 11:12 UTC
Update
Latest proxy release in AWS eu-central-1 region has caused issues with network connectivity from Kibana/APM to Elasticsearch. The release is being rolled back now. Customers might experience issues connecting to their Kibana instances. Functionality of APM might be affected.

Direct access to Elasticsearch clusters is not impacted.

We will provide status update within the next 60 minutes.
Posted 4 months ago. Jun 07, 2019 - 11:02 UTC
Investigating
We are currently investigating this issue.
Posted 4 months ago. Jun 07, 2019 - 10:47 UTC
This incident affected: GCP Frankfurt (europe-west3) (Kibana connectivity: GCP europe-west3, APM connectivity: GCP europe-west3).