Email deliverability issues.
Incident Report for Elastic Cloud
Resolved
This incident has been resolved.
Posted 7 months ago. Feb 14, 2019 - 18:53 UTC
Monitoring
We’ve identified the issue and pushed a fix. The mail backlog has been processed and all mails should be going out as usual. We will continue to monitor.
Posted 7 months ago. Feb 14, 2019 - 17:22 UTC
Investigating
We're currently experiencing email deliverability issues for system-generated alerts, including but not limited to: disk space, CPU usage, OOM events and all other watcher generated alerts.

Additionally, this is resulting in a delay for trial signup and verification emails, but you should receive these once the deliverability issues are resolved.
Posted 7 months ago. Feb 14, 2019 - 16:58 UTC